Dear Galaxy list,

I have installed Galaxy 17.05 locally and I run into an internal servor error while trying to create a workflow and also when I tried to edit an existing workflow created from history.

The log file says :

xxx/galaxy/.venv/local/lib/python2.7/site-packages/sqlalchemy/orm/ SAWarning: Got None for value of column; this is unsupported for a relationship comparison and will not currently produce an IS comparison (but may in a future release)
  "(but may in a future release)" % column) - - [20/juil./2017:11:13:15 +0200] "POST /workflow/create HTTP/1.1" 500 - "http://localhost:8080/workflow/create" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0"
Error - <type 'exceptions.AttributeError'>: 'module' object has no attribute '_magic_number'
URL: http://localhost:8080/workflow/create

File 'xxx/galaxy/.venv/local/lib/python2.7/site-packages/mako/', line 381 in _compile_from_file
  if module._magic_number != codegen.MAGIC_NUMBER:
AttributeError: 'module' object has no attribute '_magic_number'

The other options (run, copy, delete ..) in workflow are working correctly.

May you help, please.