I am attempting to install the "join" tool (Join the intervals of two datasets side-by-side) from Galaxy Tool Shed. However, I get the following error "Repository installation is not possible due to an invalid Galaxy URL: None. You may need to enable third-party cookies in your browser."

I am running a local instance of Galaxy on Ubuntu 16.04 LTS. I have attempted to install this tool on both Google Chrome and Firefox. Google Chrome is set to "Allow sites to save and read cookie data (recommended) and "Block third-party cookies" is turned off. Firefox is set to "Accept cookies and site data from websites (recommended)" and "Accept third-party cookies and site data Always". I tried restarted my Galaxy instance after ensuring that those were my broswer settings. My config.yml file has my email address set as an admin user. I have also tried restarting my computer and attempting all of those steps again.

The "join" tool works fine under "Operate on Genomic Intervals" when I use the "usegalaxy.org" instance. This is my first time trying to run a local Galaxy instance. Does anyone have any ideas on how to fix this?

Best, David