Yes it is....and my galaxy is up to date.


From: Nate Coraor <>
To: Liisa Koski <>
Date: 01/30/2012 03:07 PM
Subject: Re: [galaxy-dev] Error Setting BAM Metadata

On Jan 25, 2012, at 2:43 PM, Liisa Koski wrote:

> Hello,
> I am trying to upload BAM files (by pasting a URL) to my history(or DataLibrary) and get the following error. These are bam files which I had previously uploaded with no problems.
> Traceback (most recent call last):
>  File "/doolittle/Galaxy/galaxy_dist/lib/galaxy/jobs/runners/", line 126, in run_job
>    job_wrapper.finish( stdout, stderr )
>  File "/doolittle/Galaxy/galaxy_dist/lib/galaxy/jobs/", line 618, in finish
>    dataset.set_meta( overwrite = False )
>  File "/doolittle/Galaxy/galaxy_dist/lib/galaxy/model/", line 874, in set_meta
>    return self.datatype.set_meta( self, **kwd )
>  File "/doolittle/Galaxy/galaxy_dist/lib/galaxy/datatypes/", line 179, in set_meta
>    raise Exception, "Error Setting BAM Metadata: %s" % stderr
> Exception: Error Setting BAM Metadata: [bam_header_read] EOF marker is absent. The input is probably truncated.
> [bam_header_read] invalid BAM binary header (this is not a BAM file)
> I ran bamtools on the unix command line to see if there was anything wrong with the file(s) but nothing. I tried uploading different bam files from other projects and get the same error.
> I did do an update to the latest release yesterday...if that helps?

Hi Liisa,

Is this a regular upload via a browser?


> Thanks in advance,
> Liisa
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at: