So I was able to simulate a torque environment with
and that seemed to have worked fine. 

I did have to install the torque headers, activate galaxy's virtualenv and install

You should be seeing something like:

``` DEBUG 2018-06-14 09:23:31,549 [p:1944,w:1,m:0] [PBSRunner.work_thread-2] (2) submitting file /home/app/galaxy/database/pbs/ DEBUG 2018-06-14 09:23:31,551 [p:1944,w:1,m:0] [PBSRunner.work_thread-2] (2) queued in default queue as 3.605046c8289c DEBUG 2018-06-14 09:23:31,552 [p:1944,w:1,m:0] [PBSRunner.work_thread-2] (2) Persisting job destination (destination id: local) DEBUG 2018-06-14 09:23:31,855 [p:1944,w:1,m:0] [Dummy-5] (2/3.605046c8289c) PBS job state changed from N to R DEBUG 2018-06-14 09:23:33,994 [p:1944,w:1,m:0] [Dummy-5] (2/3.605046c8289c) PBS job has left queue
galaxy.model.metadata DEBUG 2018-06-14 09:23:34,110 [p:1944,w:1,m:0] [PBSRunner.work_thread-3] loading metadata from file for: HistoryDatasetAssociation 2 INFO 2018-06-14 09:23:34,218 [p:1944,w:1,m:0] [PBSRunner.work_thread-3] Collecting metrics for Job 2 DEBUG 2018-06-14 09:23:34,234 [p:1944,w:1,m:0] [PBSRunner.work_thread-3] job 2 ended (finish() executed in (189.200 ms))

in your logs.

Let me know how this goes.


On 14 June 2018 at 10:15, Marius van den Beek <> wrote:
Hi Sheldon,

I'm not sure what the issue could be, the PBS runner hasn't been updated in ~3 years,
but of course many things around it have been.
Could you set galaxy's logging level to debug if it isn't already and check the logs ?
When you are submitting a job in galaxy what messages are you seeing in the logs ?


On 13 June 2018 at 22:07, Briand, Sheldon (NRC/CNRC) <> wrote:

Hi Marius,


The PBS runner and the user is the galaxy user.  I do not use the run as real user option.  I haven’t been using drmaa_external_runjob_script.  This setup worked for my old 17.05 and previous versions of galaxy.





From: Marius van den Beek []
Sent: Wednesday, June 13, 2018 4:58 PM
To: Briand, Sheldon (NRC/CNRC) <>
Subject: Re: [galaxy-dev] pbs/torque jobs


Hi Sheldon,


is there anything particular about your job configuration, e.g.

are you you using the run as real user option or are you using

the drmaa_external_runjob_script option ?

Are you using the drmaa or the PBS runner ?





On 13 June 2018 at 21:13, Briand, Sheldon (NRC/CNRC) <> wrote:



I have upgraded to Galaxy 18.05 (from 17.05).  I am running a torque job scheduler (version 6.02). 


When I submit a job through galaxy and I look in the admin/manage jobs section I see that the job has been submitted successfully.  It shows that the job is queued and waiting to run.  On the cluster I see that the job runs and goes to completion.  However, the status in galaxy continue to show that the job is waiting to run and the status never gets updated.  I’m using postgres as my database and I am running through a nginx proxy.


I see no errors in my galaxy.log file.


I switched from galaxy.ini to galaxy.yml and from paste to uwsgi.  Is this a configuration problem on my end?  Where should I be looking?





Sheldon Briand

Computer Systems and Applications Analyst

National Research Council/Government of Canada Tel: (902) 426-1677


Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at: