Hi Folks,

I'm still having difficulty with this...just wondering if anyone has seen this before:

For some reason, I only had one time success with installing dexseq 1.22 in the docker galaxy, which I didn't know how it worked
out. After that, when I run biocLite("DEXSeq") again, it only installs dexseq 1.20, or even older version. I think this has something
to do with R version and bioconductor version. However, R in the conda-env doesn't run -- it has some dependency libraries missing
seems, libicui18n etc and I could not easily resolve that. :-(

Any input will be greatly appreciated.


On Tue, Jun 20, 2017 at 8:11 AM, Rui Wang <ruiwang.sz@gmail.com> wrote:
Hi Folks,

I got the galaxy docker image and played with it. However, I keep getting this when I use dexseq:

Fatal error: Exit code 1 ()
Could not import pysam, which is needed to process BAM file (though
not to process text SAM files). Please install the 'pysam' library from

Looks like there is a conda env that is built on the fly and it doesn't have some dependencies installed. If I do the following


inside the conda-env, then pysam is imported properly. Seems it installs the dexseq 1.22. I looked at the package in /tool_deps/_conda/__bioconductor-dexseq@1.20.1, 
it's 1.20.1 as the name says. I'm not sure how this could be fixed...my thought would be update the conda env dependency to include dexseq 1.22 not 1.20, but I'm not familiar with conda...Could someone give me a hand? :-)