Hi Nate,

Thanks for your reply. I already sorted out the problem. The problem was that I was accessing the galaxy instance directly, rather than going through the proxy server (nginx). However, the galaxy universe_wsgi.ini file was configured for the proxy server. Once I tried it through the proxy server, it worked like a charm.


On 31 January 2012 09:09, Nate Coraor <nate@bx.psu.edu> wrote:
On Jan 25, 2012, at 8:10 PM, Prashant Gupta wrote:

> Hi,
> I have installed the galaxy on production server. I have uploaded the files I require through ftp and now when I try to add it to the history, it gives me error "This link may not be followed from within Galaxy". However, I checked when the same galaxy distribution installed locally, it works fine. Can you please help me with this.

Hi Prashant,

At what step of the process do you receive that error message?  Can you paste any relevant entries from the Galaxy log file which might indicate what URL is being accessed that encounters this error?  If not, can you determine in your browser what URL is returning that error?


> Regards
> Prashant
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  http://lists.bx.psu.edu/