Thanks for your reply Danon

 

 I have tried to setup local galaxy-server in production mode

 

 The error that I mentioned occurred when I tried to upload file from my pc to local galaxy server( galaxy server is also installed in same pc )

 

 and my galaxy server is at the root of the domain ( http://127.0.0.1:8080)

 

 the attached file is screenshot of error and the other attached file is my nginx configuration file 

 

 Thanks for your effort in helping me 

 

 Regards

 Jonghui

 

----- Original Message -----

From: Dannon Baker [dannon.baker@gmail.com]

To: ȫ [hong@syntekabio.com]

Cc: Galaxy Dev [galaxy-dev@lists.bx.psu.edu]

Sent: Wed , November 19, 2014 23:19 PM

Subject: Re: [galaxy-dev] galaxy server file upload problem

 

Hi Johngui,
 
Can you specify which request is 404'ing -- the exact URL that's being attempted?
 
And, can you provide a little more of your nginx configuration?  Is galaxy being served at the root of the domain?
 
-Dannon

On Wed, Nov 19, 2014 at 2:01 AM, ȫ < hong@syntekabio.com > wrote:

 Hi galaxy-dev members

 

Recently we're trying to setup the galaxy server in a production mode.

 

Everything seems to be ok

 

but when I tried to upload  a file it shows error message like this

 

Failed: Not found(404)

 

I found one thread in galaxy-dev fourn about this one

 

It says that it's because of change in proxy server configuration

 

So I set exactly what was written in Galaxy wiki about nginx configuration related to proxy setting like below

 

set $dst /api/tools;

 

Should I change some oher configuration ?

 

Any kind of suggestion would be welcomed

 

Thanks

Regards

Jonghui


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/