Dear Nate,

Sorry for a lot of questions. To set up virtualenv, should I enter the root folder of "galaxy-dist" and run the commands for steps "a", "b" and "c"?

For step "b",
I only need to run "python --no-site-packages galaxy_env
" from root folder of "galaxy-dist"(don't need to run "/usr/bin/python2.6 --no-site-packages galaxy_env"), is it right?

You mentioned I need to run command from "/home/kangtu/data/tools"

/home/kangtu/Downloads/Galaxy-dist --> /home/kangtu/data/tools/galaxy-dist/

By the way, I found a folder called "galaxy_env" from root folder of "galaxy-dist" form the both folder, they are same (date, time, and size ), can I run step "b" directly from "/home/kangtu/Downloads/Galaxy-dist"?
drwxr-xr-x  5 kangtu admin 36864 2011-01-24 01:49 galaxy_env

For step "c",
is there a space in the beginning? I plan to run it from folder of "galaxy-dist"
". ./galaxy_env/bin/activate" or "../galaxy_env/bin/activate"

Looking forward to hearing from you.

Best Wishes,


On Fri, Feb 11, 2011 at 9:00 AM, Yan Luo <> wrote:
Dear Nate,

Thanks for your quick response, my colleagues of a small group are waiting for using galaxy, so it is better if we can restart it asap.

1. If I try to set up a virtualenv, do I need to recompile "bx-python"? I am not familiar with "Python", if we need to do it, could you please let me know how to do it step by step?

2. I checked your instruction you mentioned, will I follow the following steps (a, b, and c)? If it is, I will try immediately.
(a) download:
nate@weyerbacher% wget
=> `'
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 68,601 (67K) [text/x-python]

100%[====================================>] 68,601 --.--K/s

11:18:05 (729.46 KB/s) - `' saved [68601/68601]

(b) run command as follows

nate@weyerbacher% /usr/bin/python2.6 --no-site-packages galaxy_env
New python executable in galaxy_env/bin/python2.6
Also creating executable in galaxy_env/bin/python
Installing setuptools...............done.

(c)run the following 3 commands
nate@weyerbacher% . ./galaxy_env/bin/activate
nate@weyerbacher% cd galaxy_dist
nate@weyerbacher% sh


Looking forward to hearing from you.

Best Wishes,


On Fri, Feb 11, 2011 at 8:45 AM, Nate Coraor <> wrote:
Yan Luo wrote:
> Dear Nate,
> Why did you say we have 3 paths? We have a link from
> "/home/kangtu/Downloads/galaxy-dist"
> lrwxrwxrwx  1 kangtu admin        36 2010-11-01 17:07 galaxy-dist ->
> /home/kangtu/data/tools/galaxy-dist/
> from "/home/kangtu/data", we have other link as follows.
> lrwxrwxrwx  1 kangtu kangtu   28 2010-10-04 10:25 data ->
> /mnt/gluster-vol/home/kangtu
> They worked well before, when we just restarted, it has such problem, I
> couldn't start. By the way,
> 1. I have found some files as "root:root" under
> "/home/kangtu/Downloads/galaxy-dist" including its subfolders' files, so I
> changed all them  as "kangtu/admin", there is only one user right now (we
> use postgresql db).

Okay, this should be fine.

> 2. My colleague told me that he upgraded "numpy" to new version recently, is
> it the problem? how can we fix it? I checked online, someone said we need to
> recompile something (

You would need to recompile whatever depends on numpy, which in this
case is bx-python.  However, we provide our own version of numpy 1.3.
The reason that version is not being used is due to a bug in our
dependency management code which was just fixed.

There are two ways to solve this problem.  The first would be to set up
a virtualenv as suggested in my last email.

The second would be to pull our in-development code, but be aware that
this has undergone very little testing at this point.  You can pull the
most recent changes with:

 % hg pull -u


> Looking forward to hearing from you.
> Thanks,
> Yan
> On Thu, Feb 10, 2011 at 10:26 PM, Nate Coraor <> wrote:
> > Yan Luo wrote:
> > > Dear Nate,
> > >
> > > Please find the following errors, it is the newest, and our restart is
> > > stopped. I hope we can get the solution from you as soon as possible.
> >
> > Hi Yan,
> >
> > Your last 4 messages included 3 different paths to Galaxy.  It seems as
> > though there are quite a few copies of Galaxy in use here.
> >
> > To ensure there are no permissions problems, please do the following,
> > all as the same non-root user:
> >
> > 1. Remove the ~/.python-eggs directory and all of its contents.
> > 2. Clone a new copy of Galaxy.
> > 3. Start Galaxy using `./`
> >
> > And report back any errors which persist.  If the numpy error below
> > remains, I suggest setting up a Python virtualenv as described on:
> >
> >
> >
> > --nate
> >
> >