Hello Bjoern,

Yes, that solved the problem.

Thank you!



2015-11-27 17:59 GMT+01:00 Björn Grüning <bjoern.gruening@gmail.com>:
Hi Jose,

can you please try to set:

enable_beta_tool_command_isolation = True

in your galaxy.ini file?


Am 27.11.2015 um 16:01 schrieb Jose Juan Almagro Armenteros:
> I bit more of information. I have this problem running tools from the last
> version of deepTools ( , as bamCompare or bamCorrelate. However,
> when I run the same tools from the previous version (, they work
> correctly. I have reinstalled this last version but nothing. Is it possible
> that, as these two versions are using different numpy versions, bx-python
> is using the version from the deepTools package and not the one from the
> eggs?
> 2015-11-27 13:03 GMT+01:00 Jose Juan Almagro Armenteros <jjalmagro@gmail.com
>> :
>> I have tried to remove the bx-python and numpy eggs and then I have
>> fetched them again but this didn't work neither.
>> Any idea why bx-python is not recognizing the proper numpy version?
>> Regards,
>> Jose
>> 2015-11-27 0:53 GMT+01:00 Jose Juan Almagro Armenteros <
>> jjalmagro@gmail.com>:
>>> Hello,
>>> I am in the master branch and I recently pull all the changes to my local
>>> Galaxy. However, when I run one tool I obtained this error:
>>> Fatal error: Matched on Error:
>>> Traceback (most recent call last):
>>>   File "/steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/024/24973/set_metadata_GULyCa.py", line 1, in <module>
>>>     from galaxy_ext.metadata.set_metadata import set_metadata; set_metadata()
>>>   File "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy_ext/metadata/set_metadata.py", line 27, in <module>
>>>     import galaxy.model.mapping  # need to load this before we unpickle, in order to setup properties assigned by the mappers
>>>   File "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/model/mapping.py", line 21, in <module>
>>>     from galaxy.model.custom_types import JSONType, MetadataType, TrimmedString, UUIDType
>>>   File "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/model/custom_types.py", line 15, in <module>
>>>     from galaxy import app
>>>   File "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/app.py", line 14, in <module>
>>>     from galaxy.visualization.data_providers.registry import DataProviderRegistry
>>>   File "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/visualization/data_providers/registry.py", line 2, in <module>
>>>     from galaxy.visualization.data_providers import genome
>>>   File "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/visualization/data_providers/genome.py", line 16, in <module>
>>>     from bx.bbi.bigbed_file import BigBedFile
>>>   File "bigbed_file.pyx", line 1, in init bx.bbi.bigbed_file (lib/bx/bbi/bigbed_file.c:6272)
>>>   File "numpy.pxd", line 155, in init bx.bbi.bbi_file (lib/bx/bbi/bbi_file.c:12669)
>>> ValueError: numpy.dtype has the wrong size, try recompiling
>>> I suppose there is a problem with the bx-python or numpy egg but I am not
>>> really sure if is this. I run check_eggs.py and it did nothing and I also
>>> try to update numpy for the system, which didn't work neither.
>>> Do you know which numpy should I recompile in order to get this to work?
>>> Regards,
>>> Jose
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/