Hi Marius,


Yes, you were right, I was using the conda_auto_install option.  Since I first brought this up, we have been able to get most of our problems solved, and I appreciate your help.

I am again seeing the bad interpreter/text file busy message for a perl script I am trying to run.  I have tried messing with all the different combinations of use_cached_dependencies, copy_conda_dependencies, conda_auto_install, etc.  Any other ideas?



From: Marius van den Beek <m.vandenbeek@gmail.com>
Date: Tuesday, January 30, 2018 at 12:16 AM
To: John Letaw <letaw@ohsu.edu>
Cc: galaxy-dev <galaxy-dev@lists.galaxyproject.org>
Subject: Re: [galaxy-dev] Text file busy and conda


Hi John,


when you say tool autoinstalled via conda do you mean that the dependencies 

were automatically installed during the repository installation process,

or that you have `conda_auto_install = True` in your galaxy.ini ?


The latter is not working reliably while the dependencies have not finished the installation process.

To avoid this you can make sure that the dependency is correctly installed before running the tool

(the dependency in the admin panel -> Manage tool dependencies is green and no conda process is still active).





On 30 January 2018 at 03:15, John Letaw <letaw@ohsu.edu> wrote:

Hi all,


Iím receiving the following error trying to access tools autoinstalled via conda:


Fatal error: Exit code 126 ()

~/galaxy/database/jobs_directory/000/38/tool_script.sh: line 41: ~/galaxy/database/dependencies/_conda/envs/mulled-v1-bb83f93efd111e042823e53ddfa74c32d81ba74cceca9445dfddfc9e940ff738/bin/samtools: Text file busy


So, something is happening too fast I guess, meaning a process is attempting access while this is being created.  Any ideas on how I can diagnose this?  Not seeing any other errors floating around the logs.  Maybe we are dealing with a lustre file locking issue?




Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at: