Thank you for all the help Peter!

Also this is already backported and fixed in 16.01

Sorry for causing this bug in the first place. 

On Tue, Mar 22, 2016, 18:29 Peter Cock <> wrote:
Well done for solving this Fabien, with only a small hint from me.
I'm glad to see your suggested fix has already been applied to
the Galaxy repository so should be in the next stable release.

Thank you!


(Also thank you Martin, Nicola, Dan, etc)

On Tue, Mar 22, 2016 at 8:43 PM, Martin Čech <> wrote:
> Thank you very much for solving this Fabien, The PR with your fix has been
> created here:
> Martin
> On Mon, Mar 21, 2016 at 5:43 PM fmareuil <> wrote:
>> Hi Peter,
>> I worked on it today and I found  the reason of this bug. In the
>> tool, the existence of dataset.space_to_tab is tested. In the old version of
>> the data library, when the option was unchecked, the value space_to_tab was
>> None and the test worked. But in the new version the value of space_to_tab
>> is "False", it's a string and the test "if dataset.space_to_tab" returns
>> True.
>> It is possible to fix it with a little correction of the
>> "/lib/galaxy/webapps/galaxy/api/".
>> I join a patch with this email.
>> I can propose a pull request if you want.
>> Best,
>> Fabien