I am trying to upload BAM files (by pasting a URL) to my history(or DataLibrary) and get the following error. These are bam files which I had previously uploaded with no problems.

Traceback (most recent call last):
 File "/doolittle/Galaxy/galaxy_dist/lib/galaxy/jobs/runners/local.py", line 126, in run_job
   job_wrapper.finish( stdout, stderr )
 File "/doolittle/Galaxy/galaxy_dist/lib/galaxy/jobs/__init__.py", line 618, in finish
   dataset.set_meta( overwrite = False )
 File "/doolittle/Galaxy/galaxy_dist/lib/galaxy/model/__init__.py", line 874, in set_meta
   return self.datatype.set_meta( self, **kwd )
 File "/doolittle/Galaxy/galaxy_dist/lib/galaxy/datatypes/binary.py", line 179, in set_meta
   raise Exception, "Error Setting BAM Metadata: %s" % stderr
Exception: Error Setting BAM Metadata: [bam_header_read] EOF marker is absent. The input is probably truncated.
[bam_header_read] invalid BAM binary header (this is not a BAM file)

I ran bamtools on the unix command line to see if there was anything wrong with the file(s) but nothing. I tried uploading different bam files from other projects and get the same error.

I did do an update to the latest release yesterday...if that helps?

Thanks in advance,