Oh, and one more thing, when you install the tools through the playbook, do they appear in the admin section?

On 21 April 2016 at 19:37, Marius van den Beek <m.vandenbeek@gmail.com> wrote:
Okay, that was a bit too short for the tool_list.yml.
What is important is that you either have the tool_panel_section_label or tool_panel_section_id included in your tool_list.yml (for each tool!). 
Then it would help us to see what is going on if you can run the playbook with the -vvvv parameter, as well as what is going on at the same time in your galaxy logs.

On 21 April 2016 at 19:30, William Ge <wge@centrilliontech.com> wrote:

Thanks, Marius!


Sure, here it is:

I followed the online instructions to git clone the master Galaxy (Feb., 2016) and configured it for local production use with PostgreSQL and proftp. First tried ansible to install the tools, but did not succeed. Then tried the online admin installation of tools one-by-one. That worked, and I installed at least one tool for each section this way. With more help from you and others later, I got ansible-playbook to run to install the tools. That ran OK, but did not see the tools installed show up on the web frontend.


Beginning of the tool_list.yml is the same as the one included in the playbook/roles, except for the api_key and galaxy_instance:


api_key: ‘d22b682…’



-          name: ‘column_maker’

owner: …



The command I used is: ansible-playbook tools.yaml

The playbook was downloaded end of March, following the link given on the Galaxy tool installation guide.

Manual installation of the tools one-by-one from the Admin web page works. The tools installed show up on the web page.




From: Marius van den Beek [mailto:m.vandenbeek@gmail.com]
Sent: Thursday, April 21, 2016 9:45 AM
To: William Ge <wge@centrilliontech.com>
Cc: Enis Afgan <enis.afgan@irb.hr>; galaxy-dev@lists.galaxyproject.org

Subject: Re: [galaxy-dev] ERROR: PIP is not a legl parament of an Ansible Play


Hi Bill, can you describe what exactly you have done?

What would be good is if you could post the beginning of your tool_list.yml file,

the command that you used to run the playbook, the version of galaxy and the last commit

of the playbook you are using (the last entry of `git log`).

For any of this to work you should also be able manually install tools from the toolshed.

Does this work for you?


On 21 April 2016 at 18:14, William Ge <wge@centrilliontech.com> wrote:

Does anyone know why Ansible installation of the tools did not update the shed_tools_conf.xml file to reflect the installed tools? How can I make the tools installed with the Ansible playbook visible on the web front end?




From: Enis Afgan [mailto:enis.afgan@irb.hr]
Sent: Friday, April 8, 2016 9:19 AM

To: William Ge <wge@centrilliontech.com>
Cc: Marius van den Beek <m.vandenbeek@gmail.com>; galaxy-dev@lists.galaxyproject.org
Subject: Re: [galaxy-dev] ERROR: PIP is not a legl parament of an Ansible Play


The location of that dir is defined in shed_tool_conf.xml[.sample] and defaults to ../shed_tools. The reasoning is described here, under item #2: https://wiki.galaxyproject.org/DevNewsBriefs/2012_10_23#Tool_Shed


On Thu, Apr 7, 2016 at 11:09 AM, William Ge <wge@centrilliontech.com> wrote:

Thanks, Enis!

Yes, that line was uncommented with the option pointing to “tool_conf.xml,shed_tool_conf.xml”. However, I noticed that the “shed_tool_conf.xml” has not been changed after running the ansible-playbook to install tools. One other thing: the shed_tools directory was one level above the Galaxy subdirectories: i.e., all subdirectories (config, database, tool-data, tools, static, etc) are in /home/galaxy/galaxy, while “shed_tools” is in /home/galaxy. Do not know why.





From: Enis Afgan [mailto:enis.afgan@irb.hr]
Sent: Thursday, April 7, 2016 7:06 AM
To: William Ge <wge@centrilliontech.com>
Cc: Marius van den Beek <m.vandenbeek@gmail.com>; galaxy-dev@lists.galaxyproject.org

Subject: Re: [galaxy-dev] ERROR: PIP is not a legl parament of an Ansible Play


Hi Bill, 

Do you have the value set in Galaxy's $GALAXY_ROOT/config/galaxy.ini file for setting tool_config_file option? I believe this variable should be set to a file other than the default *.sample.


On Wed, Apr 6, 2016 at 9:21 PM, William Ge <wge@centrilliontech.com> wrote:

Hi, Marius,


I got ansible running and installed the tools on my local instance of Galaxy. However, the tools are not shown on the tool panel on the web page. Wonder if the tools has been installed in the wrong place, or something else is wrong. Have been searching the Wiki and list without any resulst. Please point me to the right directions.





From: Marius van den Beek [mailto:m.vandenbeek@gmail.com]
Sent: Friday, March 4, 2016 12:27 PM
To: William Ge <wge@centrilliontech.com>
Cc: Dannon Baker <dannon.baker@gmail.com>; galaxy-dev@lists.galaxyproject.org
Subject: Re: [galaxy-dev] ERROR: PIP is not a legl parament of an Ansible Play


On 4 March 2016 at 20:47, William Ge <wge@centrilliontech.com> wrote:

Thanks a lot, Marius!

Sure, you're welcome!


I am a newbie to this complex system and want a quick clone/install locally. I have spent over two weeks on the process. There are many configuration files and environment variables or dependencies to sort out. I wish the sample configuration files would include most of the options so that new installation just needs to comment out or delete unwanted ones.


The galaxy team definitely aims for this, and usually you should (tm) be able to clone galaxy and use run.sh to get going.

If you can tell us the steps where you were struggling we can try to update or clarify the documentation (A lot of it is on the wiki).

Anyway, here is the error I got:

[galaxy@Pegasus ansible-galaxy-tools]$ python files/install_tool_shed_tools.py -h
Traceback (most recent call last):
  File "files/install_tool_shed_tools.py", line 49, in <module>
    logging.captureWarnings(True)  # Capture HTTPS warngings from urllib3
AttributeError: 'module' object has no attribute 'captureWarnings'


If I run this after activating the galaxy_env and install ensible, bioblend, argparse and importlib, the same error came up. I guess this is Python 2.6 issue. Any solutions known?

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at: