Dear Leslie,

I solved the problem by using a new python installation (we use the module system to define PATH, PYTHONPATH, PYTHONUSERBASE and PYTHONHOME), without any site libraries installed.
Before in the installation I had those packages (in /software/Python/2.7.9/lib/python2.7/site-packages/) installed:


Bio                                          biopython-1.65-py2.7.egg-info      matplotlib                                pathtools-0.1.2-py2.7.egg                        setuptools
BioSQL                                       curl                               matplotlib-1.4.3-py2.7-nspkg.pth          pbr                              pyparsing.pyc                       setuptools-18.3.1.dist-info
Cython-0.22-py2.7-linux-x86_64.egg           dateutil                           matplotlib-1.4.3-py2.7.egg-info           pbr-1.8.0.dist-info              pysam                               singledispatch-
DCC-0.3.1rc0-py2.7.egg                       distribute-0.7.3-py2.7.egg-info    mock                                      pip                              pysam-        six-1.9.0-py2.7.egg
DCC-0.3.2-py2.7.egg                          easy-install.pth                   mock-1.3.0.dist-info                      pip-7.1.2.dist-info              python_dateutil-2.4.2.dist-info     sklearn
HTSeq-0.6.1p1-py2.7-linux-x86_64.egg                    mpl_toolkits                              pkg_resources                    pytz                                watchdog-0.8.3-py2.7.egg
MACS2                                        easy_install.pyc                   nose                                      poretools-0.5.1-py2.7.egg        pytz-2015.4.dist-info               wget-2.2-py2.7.egg-info
MACS2-          easy_install.pyo                   nose-1.3.7.dist-info                      pybedtools                       rpy2-2.5.6-py2.7-linux-x86_64.egg
MACS2-  funcsigs                           numpy                                     pybedtools-0.6.9-py2.7.egg-info  ruffus                              wget.pyc
PyYAML-3.11-py2.7-linux-x86_64.egg           funcsigs-0.4.dist-info             numpy-1.10.0.dev0_63e8bab-py2.7.egg-info                        ruffus-2.6.3-py2.7.egg-info
README                                       h5py-2.4.0-py2.7-linux-x86_64.egg  numpy-1.9.2-py2.7.egg-info                               scikit_learn-0.16.1-py2.7.egg-info
_markerlib                                   httplib2                           pandas                                    pylab.pyc                        scipy
argh-0.26.1-py2.7.egg                        httplib2-0.8-py2.7.egg-info        pandas-0.16.0-py2.7.egg-info              pyparsing-2.0.3.dist-info        scipy-0.15.1-py2.7.egg-info


I guess setuptools (v 18.3.1) is the cause of the incompatibility with the distribute package that galaxy_sequencing_utils downloads.
Hope this helps!


On 15 September 2015 at 10:20, Sven E. Templer <> wrote:
Hi Leslie,

I face the same problem:


Extracting in /tmp/tmplcqzT1
Now working in /tmp/tmplcqzT1/distribute-0.6.38
Building a Distribute egg in /beegfs/common/galaxy/home/server/database/tmp/tmp-toolshed-mtdqsavtj/galaxy_sequence_utils-1.0.0
Traceback (most recent call last):
  File "", line 248, in <module>
    scripts = scripts,
  File "/software/Python/2.7.9/lib/python2.7/distutils/", line 111, in setup
    _setup_distribution = dist = klass(attrs)
  File "/tmp/tmplcqzT1/distribute-0.6.38/setuptools/", line 225, in __init__
  File "/software/Python/2.7.9/lib/python2.7/distutils/", line 287, in __init__
  File "/tmp/tmplcqzT1/distribute-0.6.38/setuptools/", line 257, in finalize_options
  File "/tmp/tmplcqzT1/distribute-0.6.38/", line 2027, in require
  File "/tmp/tmplcqzT1/distribute-0.6.38/", line 2237, in requires
    dm = self._dep_map
  File "/tmp/tmplcqzT1/distribute-0.6.38/", line 2466, in _dep_map
    self.__dep_map = self._compute_dependencies()
  File "/tmp/tmplcqzT1/distribute-0.6.38/", line 2499, in _compute_dependencies
    common = frozenset(reqs_for_extra(None))
  File "/tmp/tmplcqzT1/distribute-0.6.38/", line 2496, in reqs_for_extra
    if req.marker_fn(override={'extra':extra}):
  File "/tmp/tmplcqzT1/distribute-0.6.38/_markerlib/", line 109, in marker_fn
    return eval(compiled_marker, environment)
  File "<environment marker>", line 1, in <module>
NameError: name 'sys_platform' is not defined
Traceback (most recent call last):
  File "", line 9, in <module>
  File "/beegfs/common/galaxy/home/server/database/tmp/tmp-toolshed-mtdqsavtj/galaxy_sequence_utils-1.0.0/", line 152, in use_setuptools
    return _do_download(version, download_base, to_dir, download_delay)
  File "/beegfs/common/galaxy/home/server/database/tmp/tmp-toolshed-mtdqsavtj/galaxy_sequence_utils-1.0.0/", line 132, in _do_download
    _build_egg(egg, tarball, to_dir)
  File "/beegfs/common/galaxy/home/server/database/tmp/tmp-toolshed-mtdqsavtj/galaxy_sequence_utils-1.0.0/", line 123, in _build_egg
    raise IOError('Could not build the egg.')
IOError: Could not build the egg.


It might be an issue that distribute is not maintained any more (v0.6.38 is used, 0.7.3 was latest version in 2013, then migrated to setuptools).
If you probably have updated setuptools (mine is version 18.3.1), it might cause the error.

I tried to modify to use version 0.6.49 of distribute, but got the same error.


On 10 September 2015 at 18:33, Leslie Herrera <> wrote:

My lab is currently in the process of setting Galaxy up on our server.  I have been installing the appropriate tools, but I am having difficulty installing the package_galaxy_utils_1_0.  The error message is below.  If this is something that is occuring on our end, would you please send instuctions on how to fix it?  If I have sent this email to wrong address or you need more information, please let me know.  Thank you very much for your help. 

Extracting in /tmp/tmp3dIIS_
Now working in /tmp/tmp3dIIS_/distribute-0.6.38
Building a Distribute egg in /scratch/tmp-toolshed-mtdKjroZR/galaxy_sequence_utils-1.0.0
Traceback (most recent call last):
  File "", line 248, in <module>
    scripts = scripts,
  File "/usr/lib/python2.7/distutils/", line 111, in setup
    _setup_distribution = dist = klass(attrs)
  File "/tmp/tmp3dIIS_/distribute-0.6.38/setuptools/", line 225, in __init__
  File "/usr/lib/python2.7/distutils/", line 287, in __init__
  File "/tmp/tmp3dIIS_/distribute-0.6.38/setuptools/", line 257, in finalize_options
  File "/tmp/tmp3dIIS_/distribute-0.6.38/", line 2027, in require
  File "/tmp/tmp3dIIS_/distribute-0.6.38/", line 2237, in requires
    dm = self._dep_map
  File "/tmp/tmp3dIIS_/distribute-0.6.38/", line 2466, in _dep_map
    self.__dep_map = self._compute_dependencies()
  File "/tmp/tmp3dIIS_/distribute-0.6.38/", line 2499, in _compute_dependencies
    common = frozenset(reqs_for_extra(None))
  File "/tmp/tmp3dIIS_/distribute-0.6.38/", line 2496, in reqs_for_extra
    if req.marker_fn(override={'extra':extra}):
  File "/tmp/tmp3dIIS_/distribute-0.6.38/_markerlib/", line 109, in marker_fn
    return eval(compiled_marker, environment)
  File "<environment marker>", line 1, in <module>
NameError: name 'sys_platform' is not defined
Traceback (most recent call last):
  File "", line 9, in <module>
  File "/scratch/tmp-toolshed-mtdKjroZR/galaxy_sequence_utils-1.0.0/", line 152, in use_setuptools
    return _do_download(version, download_base, to_dir, download_delay)
  File "/scratch/tmp-toolshed-mtdKjroZR/galaxy_sequence_utils-1.0.0/", line 132, in _do_download
    _build_egg(egg, tarball, to_dir)
  File "/scratch/tmp-toolshed-mtdKjroZR/galaxy_sequence_utils-1.0.0/", line 123, in _build_egg
    raise IOError('Could not build the egg.')
IOError: Could not build the egg.
Leslie A Herrera
Starr Lab Junior Specialist
MCB, 139 Briggs Hall
University of California, Davis

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at: