Thanks, Enis!

Yes, that line was uncommented with the option pointing to “tool_conf.xml,shed_tool_conf.xml”. However, I noticed that the “shed_tool_conf.xml” has not been changed after running the ansible-playbook to install tools. One other thing: the shed_tools directory was one level above the Galaxy subdirectories: i.e., all subdirectories (config, database, tool-data, tools, static, etc) are in /home/galaxy/galaxy, while “shed_tools” is in /home/galaxy. Do not know why.





From: Enis Afgan []
Sent: Thursday, April 7, 2016 7:06 AM
To: William Ge <>
Cc: Marius van den Beek <>;
Subject: Re: [galaxy-dev] ERROR: PIP is not a legl parament of an Ansible Play


Hi Bill, 

Do you have the value set in Galaxy's $GALAXY_ROOT/config/galaxy.ini file for setting tool_config_file option? I believe this variable should be set to a file other than the default *.sample.


On Wed, Apr 6, 2016 at 9:21 PM, William Ge <> wrote:

Hi, Marius,


I got ansible running and installed the tools on my local instance of Galaxy. However, the tools are not shown on the tool panel on the web page. Wonder if the tools has been installed in the wrong place, or something else is wrong. Have been searching the Wiki and list without any resulst. Please point me to the right directions.





From: Marius van den Beek []
Sent: Friday, March 4, 2016 12:27 PM
To: William Ge <>
Cc: Dannon Baker <>;
Subject: Re: [galaxy-dev] ERROR: PIP is not a legl parament of an Ansible Play


On 4 March 2016 at 20:47, William Ge <> wrote:

Thanks a lot, Marius!

Sure, you're welcome!


I am a newbie to this complex system and want a quick clone/install locally. I have spent over two weeks on the process. There are many configuration files and environment variables or dependencies to sort out. I wish the sample configuration files would include most of the options so that new installation just needs to comment out or delete unwanted ones.


The galaxy team definitely aims for this, and usually you should (tm) be able to clone galaxy and use to get going.

If you can tell us the steps where you were struggling we can try to update or clarify the documentation (A lot of it is on the wiki).

Anyway, here is the error I got:

[galaxy@Pegasus ansible-galaxy-tools]$ python files/ -h
Traceback (most recent call last):
  File "files/", line 49, in <module>
    logging.captureWarnings(True)  # Capture HTTPS warngings from urllib3
AttributeError: 'module' object has no attribute 'captureWarnings'


If I run this after activating the galaxy_env and install ensible, bioblend, argparse and importlib, the same error came up. I guess this is Python 2.6 issue. Any solutions known?

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at: