Gerrit, Renaud and others,

We apologize for the inconvenience - it seems that you have uncovered a bug that has been corrected in our development repo, but has not yet made it to our distribution repo.  This fix should reach the distribution repo some time next week.  Thanks very much for reporting this!

On Nov 11, 2010, at 9:34 AM, gerrit wrote:

Hi Greg,

I did a test and got galaxy as you said:
hg clone
Installed and same error message was given.

Then I tried the galaxy-central clone:
hg clone
Installed and now the datasets from the history can be loaded into the data library!

I've also installed the galaxy-dist on a few pcs at our lab and the same error remains! I do not want to switch to the galaxy-central fork because of the active development that can introduce bugs. There is quite a few researchers using our galaxy server so we need a stable version.

The galaxy that you're running on is a copy of the galaxy-dist, if I'm correct. I would like to reproduce the error, but cannot import any history datasets into a data library folder (do not have permissions). For a test is it possible that you can create a temporary data library for me. You can remove it as soon as I'm done. My user account is

Thanks for the help,
On Wed, Nov 10, 2010 at 4:46 PM, gerrit <> wrote:
Hi Greg,

It is a long time since I've read the documentation on your site, but since I've started with galaxy I checked it out like this:

hg clone galaxy_dist

The strange thing is then when I run "hg heads" it shows the exact version which you have.
changeset:   4354:d681ef7538ed
tag:         tip
user:        Greg Von Kuster <>
date:        Wed Sep 29 12:39:39 2010 -0400
summary:     Fix for rendering hidden widget field values associated with library templates whose fields are displayed on the upload form when importing a dataset from the current history.  Added new functional test to cover behavior.

I will test a checkout with the other update site.


On Wed, Nov 10, 2010 at 4:22 PM, Greg Von Kuster <> wrote:

I am not able to reproduce this problem, and in fact, the message being displayed looks like it comes from very old code ( this particular message "Invalid item id..." is no longer in the most recent version of the code. From where are you getting your updates?  You should be getting them from here:

To make sure you are running the latest distribution, go to your Galaxy root directory and type:

hg heads

and you should see 

4354 d681ef7538ed

On Nov 10, 2010, at 8:08 AM, gerrit wrote:

Dear Galaxy Users,

Since I've updated my Galaxy version I'm unable to import any dataset from my history into my data library. It returns a message of e.g. "Invalid item id (1464) specified".

I then did a complete new test installation to make sure that this problem wasn't because of the update. But the error still remains. I've included a screen shot in which the error is reported.

When I queried the database the dataset id does exist in the history_dataset_association table.

I went through the paster.log file and found the following warning message: Unknown library item type: <class 'galaxy.model.
HistoryDatasetAssociation'>.  Can it be that this class is not loaded or found?

Is anyone experiencing the same problem?

galaxy-user mailing list

Greg Von Kuster
Galaxy Development Team

Greg Von Kuster
Galaxy Development Team