Hello Mark,

Do you mean the GenCode reference annotation gtf dataset? This is not a reference genome. If you want to use a custom reference genome, this would be provided as a fasta file, using these instructions: https://wiki.galaxyproject.org/Support#Custom_reference_genome

My guess is that you have done the following (since a gtf file would not be accepted as a custom reference genome unless you changed the datatype to be "fasta"):

-> provided the GenCode gtf file as a "reference annotation" dataset and for mapping used a built-in "reference genome" or mapped somewhere else. When there are issues, it is most often a reference genome chromosome identifier mismatch problem. This wiki section explains this issue in more detail:

Sometimes this issue can be corrected by altering the identifiers in the gtf file to match those in the reference genome (what your fastq data was mapped to, convert BAM->SAM to see the identifiers if necessary). This FAQ shows one method:
-> https://usegalaxy.org/u/jeremy/p/transcriptome-analysis-faq#faq5

Hopefully the resources here help to resolve the issue!


Galaxy team

ps. This did not post to the mailing list because the "to" was not to just the mailing list. Please post new questions that way, or much better (since this mailing list will be retired very soon), please activate your account at Galaxy Biostar and post your question there (this has replaced the galaxy-user mailing list). Here is how: https://wiki.galaxyproject.org/Support#Biostar

On 5/20/14 12:55 AM, Mark Lindsay wrote:
Dear All

when I run Cuffmerge using the latest GenCode v19 GTF as a reference genome….this fails to run…tried this using multiple approaches and datasets.

Of note…...Cuffmerge works fine when the Gencode GTF is omitted as a reference genome. CuffCompare also works fine when the same Gencode GTF is used as a reference genome.

Presumably there is something wrong with the Cuffmerge set-up relating to the reference genome? Or am I doing something wrong.

Best wishes


Jennifer Hillman-Jackson