Hi all,

I think I have fixed this bug, and Galaxy GUI can execute MACS successfully on my cloud Galaxy.
I did the following changes to fix it:
  • It looks like the latest version of cloud Galaxy uses MACS 1.3, so I changed the default:
default -> /mnt/galaxy/tools/macs/
  • There are two path mistakes in the MACS environment variable file (/mnt/galaxy/tools/macs/, and "galaxyTools" should be "galaxy":
< PATH=/mnt/galaxy/tools/macs/$PATH
< PYTHONPATH=/mnt/galaxy/tools/macs/$PYTHONPATH
> PATH=/mnt/galaxyTools/tools/macs/$PATH
> PYTHONPATH=/mnt/galaxyTools/tools/macs/$PYTHONPATH

Maybe this can help somebody.

Lei Yan
Center for Integrative and Translational Genomics

On Tue, Sep 24, 2013 at 2:55 PM, Lei Yan <leiyan2000@gmail.com> wrote:
Hi all,

This cloud Galaxy was built by Cloud Galaxy Launch (https://main.g2.bx.psu.edu/cloudlaunch) yesterday.
I found two problems about MACS on it:
  • When I execute MACS on Galaxy GUI, I got a “not found” error. Please see attachment (error1.png).
  • If I login the Galaxy server by ssh, I found it looks like MACS was already installed on it, please see attachment (error2.png). But if I run MACS in a terminal, I got another error. Please see attachment (error3.png).
Anybody has any idea for this? Thanks a lot.

Lei Yan
Center for Integrative and Translational Genomics

On Tue, Sep 24, 2013 at 2:24 PM, Jennifer Jackson <jen@bx.psu.edu> wrote:
Hi Lawrence,

What version of MACS are you running? The Galaxy wrapper in galaxy-dist supports v1.3. I am 99% certain that the latest Cloudman image is the same, but Dannon can correct me. The two Tool Shed repos for MACS support v1.4 and v2.0.10. Making sure that the wrapper & binary are a match might be the first place to check - these can get easily confused, especially when binaries install with un-versioned symbolic links by default.

If you are re-running a workflow/job that came from the public Main server, and running galaxy-dist/central, then you want to use the v1.3 binary, unless purposefully upgrading both wrapper & binary. The workflow reproducibility tracking will alert you about a change in tool versions and permit you to select updated tools upon execution (once tool is configured) if from the same exact wrapper/tool, but not if a different wrapper/tool/repo - so will likely take a workflow edit to change out the tool in this case if upgrading to newer MACS version.

I noticed that the tool form README link for the MACS v2.0.10 wrapper is incorrect, copy link & add an ".rst" to find doc. Fairly certain these are expected to be ".txt" - I'll ask our team if this is a Tool Shed or repo input issue if extension different.

Full help for installing tools from the Tool Shed is here:

And current wrapper/binary versions in galaxy-dist/central are listed here:
With help for managing those dependencies here:

Hopefully this helps,

Galaxy team

On 9/24/13 9:41 AM, Reiter, Larry T wrote:
Thanks, James. I worked it out by downloading my data files and workflow. For some reason MACS still doesn't work. Any ideas?

Lawrence T Reiter, PhD
UTHSC, Memphis, TN

Jennifer Hillman-Jackson