[galaxy-dev] Special considerations for installing local instance of Galaxy on Mac OS X (10.6.7)?

Pieter Neerincx pieter.neerincx at gmail.com
Sat Apr 23 09:11:48 EDT 2011

Hi Jeff,

This is indeed a dependency issue and I have seen those both on Linux and Mac OS X. What happens if you type gnuplot in a Terminal window yourself? If you also get "command not found". There is either still something missing or your environment is not setup properly. If the tool works if you execute it yourself in the Terminal, but it fails in Galaxy, you do have all the dependencies and it's clearly an environment setup issue: your OS will search for the binaries in a search path defined by the $PATH environment variable. This means that if you call "gnuplot" without specifying the path where it is installed, the OS will look in all directories specified in $PATH to find it. If it cannot find it, it will give you "command not found". Additionally you may have to set $LD_LIBRARY_PATH as well if the installed tools link to libraries installed outside "default" locations.

Hence if you go to the Terminal and type:

	echo $PATH

You will see a colon separated list of directories that should include the location where the gnuplot binary is installed. If this is not the case, please Google for setting $PATH on Mac OS X. If gnuplot does work if you execute it on the commandline, but it fails in Galaxy, it most likely means the environment for the user used to run Galaxy is different from yours (and the location where gnuplot is installed is missing from $PATH). In that case you can either set the environment in the galaxy/run.sh script used to start Galaxy or if you can call a bashrc script to set the environment from galaxy/run.sh. I use the latter where I have one bashrc script that sets the environment for all users and by calling this one from galaxy/run.sh I make sure the environment for Galaxy is exactly the same as for my (command line) users.



On Apr 22, 2011, at 5:25 PM, Whyte, Jeffrey wrote:

> Hi Everyone,
> I'm having trouble getting some of the tools to work on my local installation of Galaxy on a Mac (OS X version 10.6.7).  The instructions on the GetGalaxy wiki are clear, and I was able to download and install from the anonymous Mercurial repository.  Galaxy starts up and runs just fine for tools like "Get Data", "FASTQ Groomer", and "FASTQ Summary Statistics".
> The problems started when I try to run Graph/Data Display -> Boxplot (GnuPlot).  I get the error:
> "An error occurred running this job:/bin/sh: gnuplot: command not found
> Error running gnuplot."
> The FASTX Barcode Splitter also gives me an error:
> "An error occurred running this job:/Users/Me/galaxy-dist/tools/fastx_toolkit/fastx_barcode_splitter_galaxy_wrapper.sh: line 65: fastx_barcode_splitter.pl: command not found
> zcat: /Users/Me/galaxy-dist/database/files/000/dataset_10.dat.Z: No such file or directory
> sed: illegal opt"
> I'm assuming these are Tool Dependency problems, although I have tried to install the OS X versions of GnuPlot and the FASTX Toolkit and still get errors.  
> Are there any suggestions from users who are successfully running Galaxy on OS X? 
> Thanks in advance,
> Jeff
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  http://lists.bx.psu.edu/

mobile: +31 6 143 66 783
e-mail: pieter.neerincx at gmail.com
skype:  pieter.online

More information about the galaxy-dev mailing list