[galaxy-dev] Login problem.

CHAN Chee Seng chancs at gis.a-star.edu.sg
Tue Mar 15 07:09:18 EDT 2011

Hi Ryan,

Thanks for sharing the work around.

I had the same problem.  I am running galaxy with mysql server.  I tested on
1. Firefox on a linux box
2. IE and firefox on a windows box.

I tried restarting galaxy and the apache httpd server and my client machines and nothing worked.

Finally your solution worked for firefox on both platforms but IE still has this problem.  That's fine with me, but some of my users are using IE.  :P  I have cleared all histories and cache on IE too and still have this problem.

I wonder what's caused this.  It was working fine before and suddenly this problem pops up.  Now I can't duplicate the problem on the Firefoxes.


Best regards,
Chee Seng

From: galaxy-dev-bounces at lists.bx.psu.edu [mailto:galaxy-dev-bounces at lists.bx.psu.edu] On Behalf Of Luobin Yang
Sent: Tuesday, March 15, 2011 3:43 AM
To: golharam at umdnj.edu
Cc: galaxy-dev at bx.psu.edu
Subject: Re: [galaxy-dev] Login problem.

Hi, Ryan,

Thanks for sharing your experience. It seems the issue is more serious when I use Chrome rather than Firefox.


On Fri, Mar 11, 2011 at 8:03 PM, Ryan Golhar <golharam at umdnj.edu<mailto:golharam at umdnj.edu>> wrote:

I had this same problem.  I think its a caching issue.  After you log out, try visiting a different page or click on "Analyze Data", then click on log in.  Once I navigated off the login page then came back, I was able to login.


On 3/11/11 2:17 PM, Luobin Yang wrote:
Dear Galaxy development team,

I've got a problem using the login function of Galaxy.

So I downloaded a copy of Galaxy distribution and installed it on a
local machine, then I installed PostgreSQL on this machine and made the
necessary changes to the universe_wsgi.ini file and Galaxy is able to
the use the PostgreSQL database to store information. I was able to
register a user account and then I could login to the system for the
first time, but after I logout and login again, the system always says
that I am logged out. I checked the log file of Postgresql and the log
file of Galaxy system, there is no error message indicating what
happened at all.

I restarted Postgresql database and Galaxy system and then I was able to
login, but after I logged out, I can not login again! Have you guys met
this kind of problem before? Any suggestions on what could be the cause
of this problem?

Thanks so much!

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bx.psu.edu/pipermail/galaxy-dev/attachments/20110315/c4cf4e2b/attachment.html>

More information about the galaxy-dev mailing list