Peter Cock wrote:
On Wed, Feb 2, 2011 at 6:02 PM, John David Osborne firstname.lastname@example.org wrote:
I have (or rather had) a functional galaxy installation on a CentOS box running python 2.4. I did an mecurial update for the first time and broke my installation. It looks like some eggs are getting out of date and when I run scramble.py I get an error (see below). I’m guessing this is because scramble expects python 2.5 or above for the import (import in 2.4 I don’t believe takes arguments).
Sounds like a bug.
Yes, this is a bug. I'll work on it shortly.
My question is does galaxy really still support 2.4 and should I move to python 2.7 (the current stable version) because the wiki just mentions versions 2.4 to 2.6 as being supported.
There is currently a check to prevent Galaxy running on Python 2.7, but if you remove that at the very least you'll see lots of deprecation warnings. So we decided to go with Python 2.6 here. See also: https://bitbucket.org/galaxy/galaxy-central/issue/386/python-27-support
I personally have no objection to Galaxy dropping support for Python 2.4 (in a timely manor to give existing users time to plan), it would give a bit more flexibility when writing tools for Galaxy.
Now that all modern popular operating systems I'm aware of ship at least 2.5, we will likely phase out 2.4 support. We haven't decided when this will be, but there will be a substantial amount of time between announcement and the end of support to allow adequate time to get upgraded.
galaxy-dev mailing list email@example.com http://lists.bx.psu.edu/listinfo/galaxy-dev