Sorry to dig up this old thread, but how do you remove the check that prevents galaxy running on 2.7? One of my developers just updated his workstation to Ubuntu 11.04 (Py 2.7) which is preventing him from running Galaxy. I'm not sure whether it would be better to remove this check or to just install 2.6 alongside 2.7.
-- Branden Timm email@example.com
On 2/2/2011 12:07 PM, Peter Cock wrote:
On Wed, Feb 2, 2011 at 6:02 PM, John David Osborneozborn@uab.edu wrote:
I have (or rather had) a functional galaxy installation on a CentOS box running python 2.4. I did an mecurial update for the first time and broke my installation. It looks like some eggs are getting out of date and when I run scramble.py I get an error (see below). I’m guessing this is because scramble expects python 2.5 or above for the import (import in 2.4 I don’t believe takes arguments).
Sounds like a bug.
My question is does galaxy really still support 2.4 and should I move to python 2.7 (the current stable version) because the wiki just mentions versions 2.4 to 2.6 as being supported.
There is currently a check to prevent Galaxy running on Python 2.7, but if you remove that at the very least you'll see lots of deprecation warnings. So we decided to go with Python 2.6 here. See also: https://bitbucket.org/galaxy/galaxy-central/issue/386/python-27-support
I personally have no objection to Galaxy dropping support for Python 2.4 (in a timely manor to give existing users time to plan), it would give a bit more flexibility when writing tools for Galaxy.
galaxy-dev mailing list firstname.lastname@example.org http://lists.bx.psu.edu/listinfo/galaxy-dev