1 new commit in galaxy-central:
https://bitbucket.org/galaxy/galaxy-central/commits/a223d4188a24/
Changeset: a223d4188a24
User: jgoecks
Date: 2014-05-31 01:16:30
Summary: Small fix for Trackster location routing.
Affected #: 1 file
diff -r 315997fa7d2f060a33d72950579b6b518aa4cfb0 -r a223d4188a2489c71d86f6ba0e6698573f384d7d static/scripts/viz/visualization.js
--- a/static/scripts/viz/visualization.js
+++ b/static/scripts/viz/visualization.js
@@ -1052,7 +1052,7 @@
// Can't put regular expression in routes dictionary.
// NOTE: parentheses are used to denote parameters returned to callback.
this.route(/([\w]+)$/, 'change_location');
- this.route(/([\w]+\:[\d,]+-[\d,]+)$/, 'change_location');
+ this.route(/([\w\+]+\:[\d,]+-[\d,]+)$/, 'change_location');
// Handle navigate events from view.
var self = this;
Repository URL: https://bitbucket.org/galaxy/galaxy-central/
--
This is a commit notification from bitbucket.org. You are receiving
this because you have the service enabled, addressing the recipient of
this email.
1 new commit in galaxy-central:
https://bitbucket.org/galaxy/galaxy-central/commits/315997fa7d2f/
Changeset: 315997fa7d2f
User: jmchilton
Date: 2014-05-30 23:12:40
Summary: All tool_data_table paths must now be declared with field name "path"...
... or they will not work correctly with the LWR. This is making explicit a convention that was already followed by all devteam tools. If need arises for multiple paths in the same data table or there is an important tool out there that does not label it's paths as "path" let me know and we can try to implement some XML markup in the tool_data_table.xml file to declare these fields as paths.
Use new assumption to cleanup what LWR considers unstructured paths (unstructured paths is no longer even a good name for this concept unfortunately).
Affected #: 2 files
diff -r 638dcaad4b8dcabf236d732af6f451a92cdcf2bc -r 315997fa7d2f060a33d72950579b6b518aa4cfb0 lib/galaxy/jobs/runners/lwr_client/path_mapper.py
--- a/lib/galaxy/jobs/runners/lwr_client/path_mapper.py
+++ b/lib/galaxy/jobs/runners/lwr_client/path_mapper.py
@@ -53,9 +53,6 @@
return remote_path
def check_for_arbitrary_rewrite(self, local_path):
- if not os.path.exists(local_path):
- return None, []
-
path = str(local_path) # Use false_path if needed.
action = self.action_mapper.action(path, path_type.UNSTRUCTURED)
if not action.staging_needed:
diff -r 638dcaad4b8dcabf236d732af6f451a92cdcf2bc -r 315997fa7d2f060a33d72950579b6b518aa4cfb0 lib/galaxy/tools/wrappers.py
--- a/lib/galaxy/tools/wrappers.py
+++ b/lib/galaxy/tools/wrappers.py
@@ -5,6 +5,15 @@
from logging import getLogger
log = getLogger( __name__ )
+# Fields in .log files corresponding to paths, must have one of the following
+# field names and all such fields are assumed to be paths. This is to allow
+# remote ComputeEnvironments (such as one used by LWR) determine what values to
+# rewrite or transfer...
+PATH_ATTRIBUTES = [ "path" ]
+# ... by default though - don't rewrite anything (if no ComputeEnviornment
+# defined or ComputeEnvironment doesn't supply a rewriter).
+DEFAULT_PATH_REWRITER = lambda x: x
+
class ToolParameterValueWrapper( object ):
"""
@@ -88,9 +97,6 @@
return getattr( self.value, key )
-DEFAULT_PATH_REWRITER = lambda x: x
-
-
class SelectToolParameterWrapper( ToolParameterValueWrapper ):
"""
Wraps a SelectTooParameter so that __str__ returns the selected value, but all other
@@ -112,7 +118,11 @@
def __getattr__( self, name ):
if name not in self._fields:
self._fields[ name ] = self._input.options.get_field_by_name_for_value( name, self._value, None, self._other_values )
- return self._input.separator.join( map( self._path_rewriter, map( str, self._fields[ name ] ) ) )
+ values = map( str, self._fields[ name ] )
+ if name in PATH_ATTRIBUTES:
+ # If we infer this is a path, rewrite it if needed.
+ values = map( self._path_rewriter, values )
+ return self._input.separator.join( values )
def __init__( self, input, value, app, other_values={}, path_rewriter=None ):
self.input = input
@@ -123,7 +133,9 @@
self.fields = self.SelectToolParameterFieldWrapper( input, value, other_values, self._path_rewriter )
def __str__( self ):
- return self.input.to_param_dict_string( self.value, other_values=self._other_values, value_map=self._path_rewriter )
+ # Assuming value is never a path - otherwise would need to pass
+ # along following argument value_map=self._path_rewriter.
+ return self.input.to_param_dict_string( self.value, other_values=self._other_values )
def __getattr__( self, key ):
return getattr( self.input, key )
Repository URL: https://bitbucket.org/galaxy/galaxy-central/
--
This is a commit notification from bitbucket.org. You are receiving
this because you have the service enabled, addressing the recipient of
this email.
2 new commits in galaxy-central:
https://bitbucket.org/galaxy/galaxy-central/commits/aa58945453ab/
Changeset: aa58945453ab
Branch: next-stable
User: dannon
Date: 2014-05-30 21:52:49
Summary: Fix loading indicator jqmigrate griping. Also improve it to where it's not looking for a global ajaxstart/ajaxstop.
Affected #: 1 file
diff -r cb1e86b187a38fce1b9601115fc1a51809f3b292 -r aa58945453ab7a5ced6852a731a9dabb531f27d6 static/scripts/mvc/data.js
--- a/static/scripts/mvc/data.js
+++ b/static/scripts/mvc/data.js
@@ -135,14 +135,8 @@
render: function() {
// Add loading indicator.
var loading_indicator = $('<div/>').attr('id', 'loading_indicator');
+ this.$el.append(loading_indicator);
- loading_indicator.ajaxStart(function(){
- $(this).show();
- }).ajaxStop(function(){
- $(this).hide();
- });
-
- this.$el.append(loading_indicator);
// Add data table and header.
var data_table = $('<table/>').attr({
id: 'content_table',
@@ -172,10 +166,12 @@
// If not already loading a chunk and have scrolled to the bottom of this element, get next chunk.
if ( !loading_chunk && self.scrolled_to_bottom() ) {
loading_chunk = true;
+ loading_indicator.show();
$.when(self.model.get_next_chunk()).then(function(result) {
if (result) {
self._renderChunk(result);
loading_chunk = false;
+ loading_indicator.hide();
}
});
}
https://bitbucket.org/galaxy/galaxy-central/commits/67549a8abdaf/
Changeset: 67549a8abdaf
User: dannon
Date: 2014-05-30 21:53:13
Summary: Merge next-stable.
Affected #: 1 file
diff -r 25ab1fe9dbc7659fbf3cdfea26d5f03e4c521701 -r 67549a8abdafdf2455d5190f3582c8ccfdac7a48 static/scripts/mvc/data.js
--- a/static/scripts/mvc/data.js
+++ b/static/scripts/mvc/data.js
@@ -135,14 +135,8 @@
render: function() {
// Add loading indicator.
var loading_indicator = $('<div/>').attr('id', 'loading_indicator');
+ this.$el.append(loading_indicator);
- loading_indicator.ajaxStart(function(){
- $(this).show();
- }).ajaxStop(function(){
- $(this).hide();
- });
-
- this.$el.append(loading_indicator);
// Add data table and header.
var data_table = $('<table/>').attr({
id: 'content_table',
@@ -179,10 +173,12 @@
// If not already loading a chunk and have scrolled to the bottom of this element, get next chunk.
if ( !loading_chunk && self.scrolled_to_bottom() ) {
loading_chunk = true;
+ loading_indicator.show();
$.when(self.model.get_next_chunk()).then(function(result) {
if (result) {
self._renderChunk(result);
loading_chunk = false;
+ loading_indicator.hide();
}
});
}
Repository URL: https://bitbucket.org/galaxy/galaxy-central/
--
This is a commit notification from bitbucket.org. You are receiving
this because you have the service enabled, addressing the recipient of
this email.